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Brief description

"Thunderbird" is a customized firmware for Yuneec Typhoon H (aka H480) based on PX4 Autopilot. 
It's also a synonym for a Typhoon H with this PX4 based firmware.

With Thunderbird firmware you are able to use a lot of advanced features of PX4 Autopilot with stock 
hardware of Yuneec Typhoon H (H480) in combination with RC controller ST16. Controller ST16 will 
be used unchanged. That’s why it is not part of this manual.

With the advanced software tool "QGroundControl" (QGC) you can configure, calibrate and control the
Thunderbird.
QGroundControl allows you to setup and tune all parameters of the drone, but allows you also to do the
wrong things. You should know what you do if you touch the parameters or settings.

The firmware was invented and developed by Toni Rosendahl.

First appearance (with a funny headline) was here:
https://yuneecpilots.com/threads/typhoon-h-480-px4-v1-10-stability-issues.18205

The whole project can be found at github: https://github.com/tonirosendahl/Thunderbird
Discover more about PX4 Autopilot: https://docs.px4.io/

The firmware is Open Source. Please join the community and contribute!

Important note:

You are responsible for all what you do. So, do only something if you know what you do.

Read the manuals for:
- PX4 Autopilot: https://docs.px4.io/master/en/index.html
- QGroundControl: https://docs.qgroundcontrol.com/en/

Operate Thunderbird in open area, away from people, vehicles and property.
Always be careful in what you do.

§   Follow local rules and regulations.  
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First steps

You have a complete new drone with different behavior compared to stock Typhoon H.
Get familiar with it and learn to fly the new drone. Be careful at the beginning, start in open and free 
area. Keep it away from trees.

You do not have to do anything on ST16 side. Stock settings there are OK.

It is highly recommended to read how to operate the PX4. 
https://docs.px4.io/master/en/flying/

Power on/off

To power-on the drone hold the power button down for more than 8sec until the status-LED and LEDs 
on motor arms are on.
The drone keeps silence, it plays no sound.

To power-off the drone remove the battery. Powering off is currently not possible by power button.

Arming/disarming
Arming and disarming requires the speed selector to be in FAST (rabbit) mode.

The well known red button on the ST16 does NOT arm or disarm the drone.
We need a CSC command: Hold the throttle stick in the bottom right corner until motors starting.

Important note:

Tough it is not very likely the above described CSC command may disarm the drone when hold the 
bottom right position of the throttle stick too long. To spiral down right is not a good idea to bring the 
drone down.

Flying
In default settings, the upper position of the flight mode switch is Stabilized (see hints below), middle 
position is Position Mode (Typhoon with the GPS aka Angle Mode) and lower one is Mission Mode.
RTH, Acro or Rattitude modes are not there by default. You can alter the switch configuration as you 
wish. There are two basic possibilities in QGroundControl that also could be combined:
- Switch Settings: Assign channels to flight modes, i.e. RTH to channel 10 (S2: Pan Mode),
- Flight Mode Settings: Assign flight modes to different values in channel 5 (A01) which can be set 
  in ST16 Channel Settings.
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Compared to stock Typhoon H you have to pay attention to following:

• In Position mode, the Thunderbird flies smoother. This is fine but you need more room because 
the "break path" is a bit longer than expected.

• In Stabilized mode, you have to maintain the altitude by yourself. Throttle stick means thrust in 
this case. If you pull the stick fully down, the Thunderbird comes down and I mean really down 
like a free falling stone.

• Before switch to Stabilized Mode or start in Stabilized Mode hold Throttle stick down. Middle 
Position means already middle thrust and the drone will climb immediately which may unex-
pected in this case.

• In all non-GNSS-assisted flight modes forget the ST16 screen. Keep both eyes on the drone.
• The Thunderbird is not a race drone! Keep in mind that its weight is ~2kg and it is fast. There is

no such thing like FPV available due to latency of the video down-link.
• Do not switch from non-GNSS-assisted to GNSS-assisted flight modes (Position Mode or RTH)

during high speed. It will report GPD error and will remain in non-GNSS-assisted mode. RTH 
is not possible in this case.
GPS module needs some time to get proper positioning. Let it hover in one position to switch 
the flight mode. Then wait for a couple of seconds before you proceed to fly.

• The green arrow on ST16's screen is unreliable. The arrow is there and visible, but please dis-
regard it.

Important notes:

Sonar (OBS) is not supported and is always off! Skip warning messages regarding OBS on ST16.

ESC/Motor status is not monitored by the firmware. Eventually raised Motor error/Five-Rotor Mode 
messages are telemetry glitches and can be ignored.

The ST16 is not monitoring the voltage. It waits on the Voltage Warning Flags that never come from 
Thunderbird. All pilots should be aware about that and monitor the voltage by themselves.
Don’t drain the battery down to the minimum capacity. It is better to be conservative and bring it home 
with enough fuel in the tank.

At BAT_EMERGEN_THR (Default 7%) it will raise fail-save and land wherever it is without prior 
warning.
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Sensor calibrations and settings

Sensor calibrations can only be done by QGroundControl. Connect the drone to QGC by long, flexible 
USB cable.
After changes changes, repairs and parameter file upload you need to check compass orientation 
and do a complete calibration.

Compass orientation settings
For Typhoon H exists two different compass chips. Older GPS boards have HMC5883, newer boards 
have IST8310 applied as compass chip (magnetometer). To find out which one you have, connect the 
drone to QGC and go to Mavlink console:

Type: cd /dev
then ls  and you will get a list of drivers for the hardware.

There could be "hmc5883_ext" or "ist8310_ext" as compass chip.
Note: If not all sensors are listed disconnect and reconnect to update the list.
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Important: If you have the "hmc5883_ext", you have to change External Compass Orientation to 
"ROTATION_YAW_270".
For "ist8310_ext" it must be "ROTATION_YAW_180".

Never change Autopilot orientation. It must be kept at "ROTATION_NONE".

Go to Settings > Sensors > Set Orientation

Then set External Compass Orientation to the correct value depending on you compass hardware. Save 
with "OK" and reboot the Thunderbird.

After changes do at least a compass calibration.

Read more: https://docs.qgroundcontrol.com/en/SetupView/SetupView.html
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Calibration
Remove the camera.
Go to Settings > Sensors and follow the instructions on the screen for Compass, Gyroscope, Ac-
celerometer and Level Horizon. Do not try to calibrate ESC's. It will not work and is not required.
Flight battery must be well charged to allow proper calibration.

Prepare some fitting wooden blocks that keep the drone in backward, forward and lateral positions.

Learn more: https://docs.qgroundcontrol.com/en/SetupView/sensors_px4.html

Currently there is no "wireless" way to calibrate. Be careful with the cable. Best use a longer micro 
USB data cable.

Note: If accelerometer BIAS is too high the accelerometer may need second calibration.
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Bind procedure

Ceate a new model on ST16. Type is Typhoon H. Call it "My Thunderbird" or whatever you want.
The bind process for camera CGO3+ is as usual.

To bind the 2.4GHz receiver the drone must be in bind mode. We have to use QGroundControl (QGC). 
Connect the drone to QGC by USB cable.
Go to Analyze Tools > Mavlink Console. Type: typhoon_bind start > Enter.

Then go to Bind menu of the ST16 as usual and tap on "Refresh".
Select the receiver and tap on "Bind". Reboot the drone. Done!
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Drone flight modes

Startup
Initialization

The GNSS and navigation systems are not ready. The home position is not set.
The drone can be forced to fly in non-GNSS modes but RTH will not be available during that flight. 
GNSS-assisted flight modes are degraded to "Stabilize" with or without altitude hold. The GNSS-as-
sisted modes will become available when the GNSS and estimator become ready. This will happen also
during flight, but the RTH remains inoperable until you land and take-off again, as there is no home po-
sition set for this flight. The drone takes a minute or two to start up, to be fully mission capable. This 
never happens indoors, but it is perfectly flyable there.
Status LED: GREEN blinking. The ST16 shows "Acquiring" in GPS mode display and "Start" as a 
flight mode.

Ready

The drone is ready. It has full navigation capability and home position is set.
Status LED: GREEN solid. ST16 GPS status changes from "Acquiring" to "Ready" and flight mode 
display shows also "Ready". You are good to go, no need to wait any further.

GNSS assisted flight modes
Position mode 

The Thunderbird flies like a stock Typhoon in Angle Mode.
Status LED: PURPLE solid, ST16 flight mode display: "Angle". 

Note: All sensors and GNSS must be fully operational and perfectly calibrated for these modes.

Mission mode

The Thunderbird is fully automatic. This is the automated flight mode and easiest of them all since the 
drone flies itself from take-off to motor shutdown. If no mission is available it switches back to Posi-
tion Mode.
Status LED: PURPLE blinking, ST16 flight mode display: "Waypoint".
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Stabilized flight modes
Altitude mode

Stabilized mode with altitude hold and assisted throttle. Auto-throttle is active, throttle stick controls al-
titude.
The Thunderbird flies like a stock Typhoon in Angle Mode without GPS.
Status LED: BLUE blinking, ST16 flight mode display: "THR".

Stabilize mode

Throttle controls altitude. The Thunderbird controls thrust to maintain the altitude. If the Position mode
was requested with no valid positioning solution, meaning you took off before the estimator and GNSS 
were ready, this is what you will get instead as a fallback.
This flight mode is not mapped to the mode selector switch by default at the standard parameter set-
tings. But you can summon this by requesting a position mode from a drone that took off before it was 
ready. Same as "Stability" mode, known from Blade Chroma or Blade 350QX.
Status LED: BLUE solid, ST16 flight mode display: "THR".

Note: These modes do not require GPS magnetometer being operational. Indoor flight is possible and 
magnetic interference are no issue. These modes can be used to recover the drone from GPS/magne-
tometer issues, if you'll ever encounter any. These modes require active controlling and visual line of 
sight, but they are still rather easy to fly.
Do not switch back to GNSS-assisted modes or RTH if the drone is moving fast. Let it hover to do that.
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Manual flight modes
Rattitude mode

"Assisted Acrobatics" enabled. Release the sticks and the drone should self-recover if there is enough 
altitude.
Status LED: WHITE purple blinking, ST16 flight mode display: "Rate".

Manual, Acro or Rate mode

Sticks control angular acceleration, no self-leveling, no braking, direct thrust control, absolutely zero 
assistance from the drone. The GPS, magnetometer, barometer and accelerometer are sleeping, only the
gyro data is used. You are in control now.
Same as "Agility" mode, known from Blade Chroma or Blade 350QX.
Status LED: WHITE solid, ST16 flight mode display: "Rate".

Note: These modes are not set to the mode selector switch in my default parameter file. You have to 
enable these by yourself. The "Purple solid" is a very difficult mode to fly, but allows you do anything 
with the drone.

Be careful with Acro or Rattitude mode! First learn to fly Stabilized mode.

Fail-safe mode

Fail-safes are activated (RTH) or initiated by the Autopilot. In case of low battery or failed GPS the 
drone attempts auto-land.
Status LED: RED blinking.
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Drone status LED codes

Drone status LED basic rules, regardless of color coding

1. When the LED is SOLID regardless of color, you have the full control.
2. When the LED is BLINKING, the Thunderbird is actively doing something (like assisting you 

somehow).
3. Than lighter the color, than more challenging and rewarding is it to fly.
4. Red light means malfunction, fail-safe mode or manual requested RTH.

RGB status LED details

Green: Startup
GREEN blinking: The GNSS and navigation systems are not ready and home position is not 
set. The ST16 shows "Acquiring" in GPS mode display and "Start" as a flight mode.
GREEN solid: The drone is ready. The green light will not appear when the drone is airborne. 
ST16 GPS status changes from "Acquiring" to "Ready" and flight mode display shows also 
"Ready". You are good to go, no need to wait any further.

Purple: GNSS-assisted flight
PURPLE blinking: Mission mode. ST16 flight mode display: "Waypoint".
PURPLE solid: Position mode. ST16 flight mode display: "Angle". 

Blue: Stabilized flight
BLUE blinking: Altitude mode
BLUE solid: Stabilize mode. ST16 flight mode display: "THR".

White: Manual flight modes
WHITE purple blinking: Rattitude mode or "Assisted Acrobatics".

                                                        ST16 flight mode display: "Rate".
WHITE solid: Manual, Acro or Rate mode. ST16 flight mode display: "Rate" (not tested yet).

Red: Fail-safe, RTH, malfunction
RED blinking: The drone has degraded performance, but is airborne, still operational and at-
tempts an automatic recovery. The LED blinks red when the fail-safes are activated (RTH) or 
the drone attempts auto-land with a failed GPS. It may change between red and previous color 
code for some time. However, it is recommended to bring it home at this point.
RED solid: Malfunction, arming is prohibited. ST16 flight mode display: "EMER".
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Parameter settings

Parameter settings needs to be done with QGroundControl. Changed parameters are not stored in the 
model on ST16.
It is recommended to store last working parameter set into a file before you change something. Make a 
note what parameter you have changes and why (see Parameter change sheet at the end of this docu-
ment). The stored parameter file is a backup and can be used to restore the whole parameter set in case 
of problems.

Change parameters
Power up the drone and connect it via USB to QGroundControl. 
Go to Settings (icon with gearwheels) > Parameters. Parameter sets are grouped by its functionality. To 
find a parameter you can use the search function.
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Click on the parameter you want to change. The Parameter editor appears on the right.

Change parameter (select from list or enter value) and Save. Some parameters require reboot of the 
drone.
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Save parameter sets
Go to Settings (icon with gearwheels) > Parameters > Tools > Save to file... Enter useful path and file-
name to remember what parameter set it was and save it.

Restore parameter from file

The parameter file from the last working configuration can be used to restore parameter settings in case
of problems with the new one.

Go to Settings (icon with gearwheels) > Parameters > Tools > Load from file... Select parameter file 
with last working settings and upload it to the drone. 
Reboot the drone to make the new parameter set happen. Calibration settings are part of the parameters 
and will be overwritten.
Check Compass orientation depending on compass chip and do proper calibration.

Version 1.1 from 2022-04-20 Page 17/29



Firmware update procedure using Ubuntu LINUX

Copy following files in a separate directory:
flash_typhoon_bootloader Start script
px_uploader.py Flash utility
yuneec_typhoon_h.fw The firmware itself

The file name for the firmware may change. "yuneec_typhoon_h.fw" is used here as example.

Find serial port
To find out what TTY port is used by the drone you have to disconnect and connect again the USB ca-
ble between drone and LINUX PC. Open a terminal and enter following commands:

dmesg | grep usb
dmesg | grep tty

The first command shows which USB devices where detected. The second commands shows which 
TTY port was assigned at the same time.

Here we found, the port is "ttyACM0".
Also we can see that after power-on (USB connected again) the bootloader starts first and after a while 
the Autopilot starts. If Autopilot is running we cannot flash anymore. This is the reason why we have to
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start the script for flashing prior to power-up the MCU board which must only be powered via USB. If 
we plug-in the USB cable when the script is already running we will be able to catch the bootloader.

Flashing
Now we edit the file "flash_typhoon_bootloader" to set the correct port. The file text should look like 
that:
python px_uploader.py --port /dev/ttyACM0 --force yuneec_typhoon_h.fw

In terminal, move to the directory where the three files are located and make the scripts executable: 
chmod +x ./flash_typhoon_bootloader
chmod +x ./px_uploader.py

Make sure the USB connection is cut and no battery in the drone. (MCU-board powered off).

Start firmware update script:
./flash_typhoon_bootloader

Plug in the USB cable immediately. Wait and observe terminal output. Update process will start soon...

Reboot drone after firmware was flashed successfully. Done! 
Do all checks and calibrations like for a new drone.
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Firmware update procedure for Windows

Preparation

Copy following files in an own directory:
flash_typhoon_bootloader Start script
px_uploader.py Flash utility
yuneec_typhoon_h.fw The firmware itself

The file name for the firmware may change. "yuneec_typhoon_h.fw" is used here as example.

Install Python for Windows if not yet done:
Windows key + R to open command field. 
Type cmd

The Windows terminal will be opened. Keep it open, we need it all the time.
Type python

The Windows Store will be opened and offer Python installation. Follow the instructions to install 
Python.

If Python is correctly installed it should come up with its own command line >>>.

Leave it with exit().

Then download module 'serial' for Python::
https://pypi.org/project/pyserial/#files

File name is "pyserial-3.5-py2.py3-none-any.whl", double click on it to install.

Python is installed now and we can run Python scripts like "px_uploader.py".
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Find serial port
To find out what TTY port is used by the drone you have to check the Device Manager.

Windows key + R to open command field. 
Type devmgmt.msc

The Device Manager will appear. Plug-in the USB cable to connect the drone with the PC. In node 
"Connections (COM & LPT)" an item "Legacy FMU" with a COM number appears.

Here we found, the port is "COM8".

Now we edit the file "flash_typhoon_bootloader" to set the correct port and save it as 
"flash_typhoon_bootloader.bat" to make it executable. The file text should look like that:
python px_uploader.py --port COM8 --force "yuneec_typhoon_h.fw"

Flashing

Note: After power-on the bootloader starts first and after a while the flight controller starts. If flight 
controller is running we cannot flash anymore. This is the reason why we have to start the script for 
flashing prior to power-up the MCU board which is powered by flight battery. If we plug-in the USB 
cable when the script is already running we will be able to catch the bootloader.
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Make sure the USB connection is unplugged (MCU-board powered off).

Start firmware update script:
flash_typhoon_bootloader.bat

Plug in the USB cable. Then hold the start button of the aircraft down until flashing is complete, dis-
connect and connect USB cable again. Wait and observe terminal output.
Update process will start soon …

Done!

Reboot drone after firmware was flashed successfully.

Start QGroundControl and reload parameters (your parameter backup or the default parameter set that 
came with latest firmware).
Vehicle Setup > Parameters > Tools > Load from file… > Select the parameter file.
Reboot again.

Do all checks and calibrations like for a new drone.
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Annex

Recommended settings
Parameter reference: https://docs.px4.io/v1.9.0/en/advanced_config/parameter_reference.html

Parameter from to Description

MPC_Z_VEL_MAX_DN 1.000 3.000 Max. descent speed [m/s] as it was at H480

MPC_Z_VEL_MAX_UP 3.0 5.0 Max. ascent speed [m/s] as it was at H480

MC_RATT_TH 0.80 0.60 Threshold for Stabilized in Rattitude mode [%] for 
more Acro to get smoother rolls or loopings

COM_ARM_WO_GPS Disabled
(0)

Enabled
(1)

For indoor flights. For GNSS-assisted flights wait for
solid green LED status.

RTL_RETURN_ALT 30m x Keep default Return altitude or change it to a value x 
that fits better to your area.

Flight Modes:

QGroundControl > Flight Modes > Flight Mode Settings:
Mode Channel = Channel 5
Flight Mode 6: change from Stabilized to Altitude. Altitude Mode is the same as Typhoon H with GPS
off.

QGroundControl > Flight Modes > Switch Settings:
Return Switch Channel: Change from Unassigned to Channel 10. In this case S2 Pan Mode lowest po-
sition is RTH. This switch overwrites all other flight modes.

Notes: 
• Test changed flight modes without propellers before you use this settings in real flight sessions.
• All tuning measurements and parameter setting may influence flight behavior and security. Do 

it on your own risk.
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Some helpful MAVLink Console commands

The MAVLink Console opens a PX4 NSH shell to send commands and receive results when the aircraft
is powered on and connected to QGroundControl.

More about the NSH shell: https://dev.px4.io/v1.9.0/en/debug/system_console.html

Help

? Shows a list of commands and Build-in Apps:

Those shell commands maybe helpful just for information or for troubleshooting. Please execute com-
mands only if you know what you do. Refer to the PX4 Autopilot documentation and QGroundControl 
manual.
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Following commands can be executed without problems, do not change anything and are only used to 
show some information.
How to use custom command typhoon_bind please refer to the Thunderbird user manual.

File system

ls List files or dirctories
cd fs/microsd Change directory to list the files on micro SD card
ls -l List the files or directories on micro SD card
cd / Change directory to root directory

With the commands above you can check if you have an SD card inserted and if it is readable.

To download flight logs (ULOG files: *.ulg) use QGroundControl Analyze > Log Download.
Click on Refresh to see updated list of ULOG files.
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Devices

ls List directories in root diectory
cd dev Change directory to ‘dev’
ls List devices of the drone
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System

df Show memory sizes
df -h Show memory sizes in ‘human readable’ format
free Show free/used memory
date Show system time
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Parameter change sheet

It is recommended to note your parameter settings and its history. Print this sheet.

Note: Channel settings on ST16 are stored to the related models. If you want to reset Channel settings, 
create a new model from scratch.
Parameter settings in QGroundControl are not stored in the model on ST16.

Date Parameter from to Description/reason
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Cheat sheet
Proposal for brief description to print it.

Flight mode switch setting (fill table with your own settings)

FlightMode Switch Position

Position (Angle 
mode)

Flight mode switch S4 middle

Altitude (GNSS sup-
port off)

Flight mode switch S4 upper

Stabilized (Manual) Aux switch B2 upper

Rattitude Aux switch B2 lower

Acro

Mission Flight mode switch S4 lower

RTH Pan mode switch S2 lower

Power on/off

Power on: Hold power button on drone for 8sec until LEDs are on.
                  The Speed Slider must be set to “Rabbit”!
Power off: Remove battery

Motor Start / Stop

Hold throttle stick in the lower right corner

Flying

✔ Check location (rules and regulations)
✔ Free space for GPS signals, no potential reflectors to avoid multi-path 

reception
✔ Drone battery full, ST16 battery full
✔ Check battery voltage during flight

Bind mode: nsh shell command "typhoon_bind start"
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